db-move: moved grilo from [testing] to [extra] (x86_64)
[arch-packages.git] / grilo-plugins / repos / testing-x86_64 / PKGBUILD
blob396502d52d6bd971abd9ea9033ee967345873625
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=grilo-plugins
4 pkgver=0.3.16
5 pkgrel=1
6 epoch=1
7 pkgdesc="A collection of plugins for the Grilo framework"
8 url="https://gitlab.gnome.org/GNOME/grilo-plugins"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   chromaprint
13   gom
14   grilo
15   gst-plugins-bad
16   libdmapsharing
17   libgoa
18   libmediaart
19   lua
20   tracker3
22 makedepends=(
23   git
24   gperf
25   meson
26   yelp-tools
28 checkdepends=(
29   gst-plugins-base
30   gst-plugins-good
31   python-gobject
32   tracker3-miners
34 optdepends=(
35   'dleyna-server: DLNA plugin'
36   'tracker3-miners: Tracker plugin'
38 groups=(gnome)
39 _commit=dff5616464b8e46f58b84a67cc945f3a6c72dd73  # tags/grilo-plugins-0.3.16^0
40 source=(
41   "git+https://gitlab.gnome.org/GNOME/grilo-plugins.git#commit=$_commit"
42   no-tracker-test.diff
44 b2sums=('SKIP'
45         '7ef8315121f11f8fff3162cf535f5d03e2a1587aa8db86ebd481253d23aa3570e48fcb363049f0c393e5b6c8799c8765c33a32f73c098772e72e22ae13aae14d')
47 pkgver() {
48   cd $pkgname
49   git describe --tags | sed 's/^grilo-plugins-//;s/[^-]*-g/r&/;s/-/+/g'
52 prepare() {
53   cd $pkgname
55   # Tracker test broken in our containers because bubblewrap stopped working,
56   # also see https://bugs.archlinux.org/task/78033
57   git apply -3 ../no-tracker-test.diff
60 build() {
61   local meson_options=(
62     -D enable-tracker=no
63   )
65   arch-meson $pkgname build "${meson_options[@]}"
66   meson compile -C build
69 check() {
70   dbus-run-session meson test -C build --print-errorlogs
73 package() {
74   depends+=(libgr{ilo,lnet,lpls}-0.3.so)
75   meson install -C build --destdir "$pkgdir"
78 # vim:set sw=2 sts=-1 et: