OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-dictionary / trunk / PKGBUILD
blob51fb551e8735080ae9655f4478de6863ce58ca9d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-dictionary
5 pkgver=40.0
6 pkgrel=1
7 pkgdesc="Look up words in dictionary sources"
8 url="https://wiki.gnome.org/Apps/Dictionary"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(gtk3)
12 makedepends=(yelp-tools git meson appstream-glib)
13 _commit=c37edfc2cbf91d6bae6d5264d0dcfcb5dd34b313  # tags/40.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-dictionary.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build
35 package() {
36   DESTDIR="$pkgdir" meson install -C build
39 # vim:set ts=2 sw=2 et: