OCaml 4.14.0 rebuild
[arch-packages.git] / gsettings-desktop-schemas / trunk / PKGBUILD
blob108f53f9fc60793993cc3c1dbc69797eb198d6fb
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
4 # Contributor: Adam Hani Schakaki (krzd) <krzd@krzd.net>
6 pkgname=gsettings-desktop-schemas
7 pkgver=42.0
8 pkgrel=1
9 pkgdesc="Shared GSettings schemas for the desktop"
10 url="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
11 arch=(any)
12 license=(GPL)
13 depends=(glib2 dconf cantarell-fonts adobe-source-code-pro-fonts)
14 makedepends=(gobject-introspection git meson)
15 _commit=a1f3cd8de0e3d67c826aebce35cc53f760836dca  # tags/42.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"