OCaml 4.14.0 rebuild
[arch-packages.git] / tomcat-native / repos / extra-x86_64 / PKGBUILD
blob7e06ed51013cb3ea8c74510157cd15938b3b41bd
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Guillaume Alaux <guillaume@archlinux.org>
3 # Contributor: Vitaliy Berdinskikh <ur6lad@i.ua>
5 pkgname=tomcat-native
6 pkgver=1.2.35
7 pkgrel=1
8 pkgdesc='Optional component for Tomcat to use certain native resources for performance, compatibility'
9 arch=(x86_64)
10 url=https://tomcat.apache.org/native-doc/
11 license=(APACHE)
12 depends=(apr)
13 makedepends=(
14   git
15   java-environment
16   python
18 options=(!emptydirs)
19 _tag=4dcb5e1f0a9cf2094f84fe1872272cff70fadb9b
20 source=(
21   git+https://github.com/apache/tomcat-native.git#tag=${_tag}
22   tomcat-native-buildconf.patch
24 b2sums=(
25   SKIP
26   d3603079626b908644331c193452088ef3ce89e92c775c60b232d16d04b8c49d40106d55c76f81c87daea93d335868140df0046c7102796d92b08431ac8749a4
29 pkgver() {
30   cd tomcat-native
32   git describe --tags
35 prepare() {
36   cd tomcat-native/native
38   patch -Np2 -i ../../tomcat-native-buildconf.patch
39   automake --add-missing --copy --force-missing || true
40   ./buildconf \
41     --with-apr=/usr/share/apr-1
44 build() {
45   cd tomcat-native/native
47   ./configure \
48     --prefix=/usr \
49     --with-apr=/usr/bin/apr-1-config \
50     --with-java-home=/usr/lib/jvm/default \
51     --with-ssl=/usr
52   make
55 package() {
56   make DESTDIR="${pkgdir}" -C tomcat-native/native install
59 # vim: ts=2 sw=2 et: