1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Movie player for the GNOME desktop based on GStreamer"
8 url="https://wiki.gnome.org/Apps/Videos"
11 depends=(totem-plparser iso-codes libpeas grilo gsettings-desktop-schemas
12 python-gobject gnome-desktop gst-plugins-base gst-plugins-good
13 gst-plugins-bad gst-plugin-gtk libhandy)
14 makedepends=(libnautilus-extension itstool docbook-xsl python-pylint
15 gobject-introspection git appstream-glib gtk-doc meson intltool)
16 optdepends=('gst-plugins-ugly: Extra media codecs'
17 'gst-libav: Extra media codecs'
18 'grilo-plugins: Media discovery')
19 conflicts=(totem-plugin)
20 replaces=(totem-plugin)
23 _commit=d578333de76dc51f7a58bd84edee8ee93f5050e3 # tags/42.0^0
24 source=("git+https://gitlab.gnome.org/GNOME/totem.git#commit=$_commit"
25 "git+https://gitlab.gnome.org/GNOME/libgd.git")
31 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
38 git submodule set-url subprojects/libgd "$srcdir/libgd"
43 arch-meson totem build -D enable-gtk-doc=true
44 meson compile -C build
48 meson install -C build --destdir "$pkgdir"
49 install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 totem/COPYING