db-move: moved webkit2gtk from [staging] to [testing] (x86_64)
[arch-packages.git] / gsm / repos / extra-x86_64 / PKGBUILD
blob04c08aae020618a15b3bdbd0ea25640222e5c1df
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Maxime de Roucy <maxime.deroucy@gmail.com>
3 # Contributor: Darwin Bautista <djclue917@gmail.com>
5 pkgname=gsm
6 pkgver=1.0.22
7 pkgrel=1
8 pkgdesc="Shared libraries for GSM 06.10 lossy speech compression"
9 arch=('x86_64')
10 url="https://www.quut.com/gsm/"
11 license=('custom')
12 depends=('glibc')
13 source=("https://www.quut.com/$pkgname/$pkgname-$pkgver.tar.gz" gsm-shared.patch gsm-fix-toast-install.patch)
14 sha512sums=('f4284f096ed4d606ddece5c1b28edb63feacc26a0b664f1350c040dbf50113d27bedfd9896bf1620cb4fc3a6c8f6a5244955a6c625ded833dcee607c63c97dd2'
15             '5833f9157ab5adf68b3ad0b6316ec563389fe39dd7b99ee04acc08a32bfccf9f517b9289ce3bfd32e191ab8a4b674c08ea1fbba9411e43c0d44f78f24bf885cd'
16             '88f3214e92d4f5b9dae9c5d67073abb36c7889cdcb90a00fb023794ae474c0560d8ea5098ce3e5424a1021fe44cd4f6b91d86c77e4b864fe97b51d69debf0c5d')
18 prepare() {
19   cd $pkgname-${pkgver%.*}-pl${pkgver##*.}
21   patch -p0 -i ../gsm-shared.patch
22   patch -p0 -i ../gsm-fix-toast-install.patch
25 build() {
26   cd $pkgname-${pkgver%.*}-pl${pkgver##*.}
28   make CCFLAGS="-c ${CFLAGS} -fPIC"
31 package() {
32   cd $pkgname-${pkgver%.*}-pl${pkgver##*.}
34   # Prepare directories
35   install -m755 -d "$pkgdir"/usr/{bin,lib,include/gsm,share/{licenses/$pkgname,man/man{1,3}}}
37   make -j1 INSTALL_ROOT="$pkgdir"/usr \
38     GSM_INSTALL_INC="$pkgdir"/usr/include/gsm \
39     GSM_INSTALL_MAN="$pkgdir"/usr/share/man/man3 \
40     TOAST_INSTALL_MAN="$pkgdir"/usr/share/man/man1 \
41     install
43   # Install license
44   install -m644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/license.txt