db-move: moved webkit2gtk from [staging] to [testing] (x86_64)
[arch-packages.git] / ndctl / trunk / PKGBUILD
blob11a08a5960d208e387e7e429112b47b51726b8a4
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=ndctl
4 pkgver=76.1
5 pkgrel=1
6 pkgdesc='Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel'
7 arch=('x86_64')
8 url="https://github.com/pmem/ndctl"
9 license=('LGPL')
10 depends=('iniparser' 'json-c' 'keyutils' 'kmod' 'libtraceevent' 'libtracefs' 'systemd-libs'
11          'util-linux-libs')
12 makedepends=('asciidoctor' 'bash-completion' 'cmake' 'meson' 'systemd' 'xmlto')
13 source=("https://github.com/pmem/ndctl/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('76d32599df029969734276f8972f3f4bf701e471117c8a48d1f96b62c87a59ac54d59104ee62d1cbbb518a06a779677ca856df32ce6218d758a8c73daa3e5b06')
16 prepare() {
17   # fix location of modprobe.d conf
18   sed -i "s|^modprobedatadir =.*|modprobedatadir = '/usr/lib/modprobe.d/'|" $pkgname-$pkgver/contrib/meson.build
21 build() {
22   arch-meson $pkgname-$pkgver build
23   meson compile -C build
26 check() {
27   meson test -C build --print-errorlogs
30 package() {
31   meson install -C build --destdir "$pkgdir"