1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-languageserver
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='An implementation of the Language Server Protocol'
13 makedepends=(cmake ninja)
15 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
16 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
17 sha256sums=('8dc8d3d2f3a345628e91ce1c366709e78971eb9c4d26836a8cd787a51f8f1a1d')
20 cmake -B build -S $_pkgfn -G Ninja \
21 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
26 DESTDIR="$pkgdir" cmake --install build
28 install -d "$pkgdir"/usr/share/licenses
29 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname