db-move: moved webkit2gtk from [staging] to [testing] (x86_64)
[arch-packages.git] / xorg-xcursorgen / trunk / PKGBUILD
blob22f9e453b34300e6aee4750536fc4648370fa98d
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xorg-xcursorgen
5 pkgver=1.0.8
6 pkgrel=1
7 pkgdesc="Create an X cursor file from PNG images"
8 arch=('x86_64')
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libx11' 'libxcursor' 'libpng')
12 makedepends=('xorg-util-macros')
13 groups=('xorg-apps' 'xorg')
14 source=(https://xorg.freedesktop.org/archive/individual/app/xcursorgen-${pkgver}.tar.xz{,.sig})
15 sha512sums=('dede5b9e1e09f9253365bbb83fdab26c681641913f3586cef52d4802db9cecc7e252344911cd969a873c3a5c5ebbd4b862f786de263f92ea1bcb2df90236f9c4'
16             'SKIP')
17 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # "Alan Coopersmith <alan.coopersmith@oracle.com>"
19 build() {
20   cd xcursorgen-${pkgver}
21   ./configure --prefix=/usr
22   make
25 package() {
26   cd xcursorgen-${pkgver}
27   make DESTDIR="${pkgdir}" install
28   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
29   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"