1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Pierre Schmitz <pierre@archlinux.de>
8 pkgdesc='The Apache Portable Runtime'
10 url='https://apr.apache.org/'
11 depends=('util-linux')
12 makedepends=('python')
14 source=(https://dlcdn.apache.org/apr/apr-$pkgver.tar.bz2{,.asc}
16 ship_find_apr.m4.patch
19 dont_override_external_buildflags
20 fix_autoconf_270.patch::https://github.com/apache/apr/commit/0a763c5e500f4304b7c534fae0fad430d64982e8.patch)
21 sha256sums=('e2e148f0b2e99b8e5c6caa09f6d4fb4dd3e83f744aa72a952f94f5a14436f7ea'
23 '91490ffee726f851edad9fc733ac6632aaf434a87920e706eeb132a97ee5f402'
24 '315932ef6536fc0644c1efe770ceb3bb675c3c7103a7cbb2f02efd8be03eb752'
25 '12595d331b48be9e44bd843635eb4f0f500bd213e197a551a9d383a28a24641f'
26 '3d491d3af8fb5a75db4e085a17e5d8dcbe058bd256ef893ee779dc97fc9f8ad6'
27 '5ac0bdc532479f6082d29115ac9d3ca24524fd8b97a556568755b88e5a68e3df'
28 'b94df1f18d4a3e1aba4ef55fa987f5292c876620094bb0a859ff6678f5555cb6')
29 validpgpkeys=('5B5181C2C0AB13E59DA3F7A3EC582EB639FF092C' # Jeff Trawick
30 'B1B96F45DFBDCCF974019235193F180AB55D9977') # Nick Kew <niq@apache.org>
34 patch -Np1 -i ../fix_apr-config.patch
35 patch -Np1 -i ../ship_find_apr.m4.patch
36 patch -Np1 -i ../fix-apr.pc.patch
37 patch -Np1 -i ../omit_extra_libs.patch
38 patch -Np1 -i ../dont_override_external_buildflags
39 patch -Np1 -i ../fix_autoconf_270.patch # FS#71783
45 ./configure --prefix=/usr --includedir=/usr/include/apr-1 \
46 --with-installbuilddir=/usr/share/apr-1/build \
47 --enable-nonportable-atomics \
48 --with-devrandom=/dev/urandom --disable-static
49 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
60 make DESTDIR="$pkgdir" install