upgpkg: sbcl 2.2.11-1
[arch-packages.git] / compsize / repos / extra-x86_64 / PKGBUILD
blobf1c469b0959014618cae8638d6054a40a506e41a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=compsize
4 pkgver=1.5
5 pkgrel=1
6 pkgdesc="Calculate compression ratio of a set of files on Btrfs"
7 arch=(x86_64)
8 url="https://github.com/kilobyte/compsize"
9 license=(GPL)
10 depends=(glibc)
11 makedepends=(btrfs-progs git)
12 _commit=0ae6d84b3ac1ac62f6976ce6bf1aa9bb94e83391  # tags/v1.5^0
13 source=("git+$url#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^v//;s/-/+/g'
21 build() {
22   cd $pkgname
23   make
26 package() {
27   cd $pkgname
28   install -d "$pkgdir/usr/share/man/man8"
29   make install PREFIX="$pkgdir/usr"