upgpkg: sbcl 2.2.11-1
[arch-packages.git] / ibus-typing-booster / repos / extra-any / PKGBUILD
bloba6854807ce4e2f694f3ee50cf50fb0b03b059d5b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=ibus-typing-booster
4 pkgver=2.19.8
5 pkgrel=1
6 pkgdesc="Predictive input method for the IBus platform"
7 url="https://mike-fabian.github.io/ibus-typing-booster/"
8 arch=(any)
9 license=(GPL3 Apache)
10 depends=(ibus python-gobject python-dbus python-pyenchant m17n-lib sqlite)
11 makedepends=(git)
12 _commit=b0963e36b181718001d8a35baaa910ab7bc0162f  # tags/2.19.8
13 source=("git+https://github.com/mike-fabian/ibus-typing-booster#commit=$_commit")
14 sha512sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
21 prepare() {
22   cd $pkgname
23   autoreconf -fvi
26 build() {
27   cd $pkgname
28   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
29     --libexecdir=/usr/lib/ibus
30   make
33 package() {
34   cd $pkgname
35   make DESTDIR="$pkgdir" install
37   cd "$pkgdir/usr/share/$pkgname/data"
38   gzip -nf --best *.{txt,json} annotations{,Derived}/*.xml
41 # vim:set sw=2 sts=-1 et: