1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
3 # Contributor: Andreas Radke <andyrtr@archlinux.org>
6 pkgname=('icedtea-web' 'icedtea-web-doc')
9 pkgdesc='Additional components for OpenJDK - Browser plug-in and Web Start implementation'
10 url='https://github.com/AdoptOpenJDK/IcedTea-Web'
13 makedepends=('java-environment=8' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'junit'
14 'firefox' 'epiphany' 'rust' 'bc')
15 optdepends=('rhino: for using proxy auto config files')
16 source=(https://github.com/AdoptOpenJDK/IcedTea-Web/archive/${pkgbase}-${pkgver}.tar.gz
18 sha256sums=('f4203a605a3c9c50acdcc6eef4a366b9fdd36d95edcd76bcbfede01107cb5fe6'
19 '4db38a59012bf4c3dc857f340924ecbc796d89f15521abdc367bc39301be7a19')
20 sha512sums=('99f246ce603e3edd4357a2c4d280f1ef92e1f760ca5d843eaccf7ca60950a47defec64eed87dac26c5c2e9776bed2f3e53f2c8793dabd47e1b5fc82823190dcc'
21 '0689abbe5fa5b616a3c71caf038a42bc69a4950e923cce3c658c15a85a140f5d2e19a96429fc82cfe38c42fdc7bca4a305fd613e3483a8f98a6ee3daaf0a8304')
24 cd IcedTea-Web-${pkgbase}-${pkgver}
25 patch -Np0 < "${srcdir}/compiler-flags.patch"
30 cd IcedTea-Web-${pkgbase}-${pkgver}
32 --prefix=/usr/share/${pkgbase} \
33 --datarootdir=/usr/share \
34 --with-jdk-home=/usr/lib/jvm/default \
35 --with-jre-home=/usr/lib/jvm/default-runtime \
36 --with-java=/usr/bin/java \
37 --with-browser-tests \
38 --with-firefox=/usr/bin/firefox \
39 --with-epiphany=/usr/bin/epiphany \
40 --with-itw-libs=DISTRIBUTION
45 cd IcedTea-Web-${pkgbase}-${pkgver}
50 package_icedtea-web() {
51 depends=('java-runtime-openjdk' 'desktop-file-utils')
52 provides=('java-web-start')
54 cd IcedTea-Web-${pkgbase}-${pkgver}
55 make DESTDIR="${pkgdir}" install
57 # Install desktop files
58 install -Dm 644 javaws.png -t "${pkgdir}"/usr/share/pixmaps
59 install -Dm 644 *.desktop -t "${pkgdir}"/usr/share/applications
61 ## link binaries into /usr/bin + jre/bin
62 install -m 755 -d "${pkgdir}"/usr/bin
63 for file in "${pkgdir}/usr/share/${pkgbase}/bin/"*; do
64 ln -sf "/usr/share/${pkgbase}/bin/$(basename "${file}")" "${pkgdir}"/usr/bin
67 ## link the mozilla-plugin - test it here http://www.java.com/en/download/help/testvm.xml
68 install -m 755 -d "${pkgdir}"/usr/lib/mozilla/plugins/
69 ln -sf /usr/share/${pkgbase}/lib/IcedTeaPlugin.so "${pkgdir}"/usr/lib/mozilla/plugins/
71 # remove splitted doc files
72 rm -rf "${pkgdir}"/usr/share/doc
75 package_icedtea-web-doc() {
76 pkgdesc+=' (documentation)'
78 cd IcedTea-Web-${pkgbase}-${pkgver}
79 make DESTDIR="${pkgdir}" install-data-local
80 # remove javaws about and man page
81 rm -rf "${pkgdir}"/usr/lib
82 rm -rf "${pkgdir}"/usr/share/man
83 rm -rf "${pkgdir}"/usr/share/icedtea-web