upgpkg: sbcl 2.2.11-1
[arch-packages.git] / kwin / repos / extra-x86_64 / PKGBUILD
blobd187d4a249fa8f52944065e5192b8952e81f7830
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kwin
6 pkgver=5.26.4
7 pkgrel=1
8 pkgdesc='An easy to use, but flexible, composited Window Manager'
9 arch=(x86_64)
10 url='https://kde.org/plasma-desktop/'
11 license=(LGPL)
12 depends=(kscreenlocker xcb-util-cursor plasma-framework kcmutils breeze
13          pipewire-session-manager libqaccessibilityclient lcms2 libxcvt)
14 makedepends=(extra-cmake-modules qt5-tools kdoctools krunner wayland-protocols plasma-wayland-protocols python)
15 optdepends=('maliit-keyboard: virtual keyboard for kwin-wayland')
16 replaces=(kwayland-server)
17 groups=(plasma)
18 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
19 install=$pkgname.install
20 sha256sums=('2650db6006fe916ee2d48ff1083d4a5775fb0cf51ccdf01ac08dc1abbed300b9'
21             'SKIP')
22 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
23               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
24               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
25               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
26 options=(debug)
28 build() {
29   cmake -B build -S $pkgname-$pkgver \
30     -DCMAKE_INSTALL_LIBEXECDIR=lib \
31     -DBUILD_TESTING=OFF
32   cmake --build build
35 package() {
36   DESTDIR="$pkgdir" cmake --install build