upgpkg: sbcl 2.2.11-1
[arch-packages.git] / lcms2 / repos / extra-x86_64 / PKGBUILD
blobe72bc46c3945ce356857587076d9b0247bf664e1
1 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
3 pkgname=lcms2
4 pkgver=2.14
5 pkgrel=1
6 pkgdesc='Small-footprint color management engine, version 2'
7 arch=('x86_64')
8 url='http://www.littlecms.com/'
9 license=('MIT')
10 depends=('libtiff')
11 provides=('liblcms2.so')
12 source=("https://github.com/mm2/Little-CMS/releases/download/lcms${pkgver}/${pkgname}-${pkgver}.tar.gz")
13 sha256sums=('28474ea6f6591c4d4cee972123587001a4e6e353412a41b3e9e82219818d5740')
15 build() {
16   cd "${pkgname}-${pkgver}"
18   ./configure \
19     --prefix=/usr
20   make
23 check() {
24   cd "${pkgname}-${pkgver}"
26   make check
29 package() {
30   cd "${pkgname}-${pkgver}"
32   make DESTDIR="${pkgdir}" install
33   install -D -m0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"