upgpkg: sbcl 2.2.11-1
[arch-packages.git] / libkgapi / repos / kde-unstable-x86_64 / PKGBUILD
blob0ee111368815827afdaec9d358a3eb87e7ce0a58
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=libkgapi
5 pkgver=22.11.90
6 pkgrel=1
7 pkgdesc='A KDE-based library for accessing various Google services via their public API'
8 url='https://www.kde.org/'
9 arch=(x86_64)
10 license=(GPL LGPL FDL)
11 depends=(kcalendarcore kcontacts kwallet)
12 makedepends=(extra-cmake-modules qt5-tools)
13 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('afa1a97c0fb8e4701e43ec8aa23365eb9d362b519840166e811886c74d4cb04d'
15             'SKIP')
16 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
17               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
18               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
19 options=(debug !lto) # https://bugs.kde.org/show_bug.cgi?id=411425
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build