upgpkg: sbcl 2.2.11-1
[arch-packages.git] / libndp / repos / extra-x86_64 / PKGBUILD
blob00a9c3601c3448fb7df13965dc5537a9c11af357
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=libndp
4 pkgver=1.8
5 pkgrel=1
6 pkgdesc="Library for Neighbor Discovery Protocol"
7 arch=(x86_64)
8 url="http://libndp.org/"
9 license=(LGPL)
10 depends=(glibc)
11 makedepends=(git)
12 _commit=009ce9cd9b950ffa1f4f94c9436027b936850d0c  # tags/v1.8
13 source=("git+https://github.com/jpirko/libndp#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^v//;s/-/+/g'
21 prepare() {
22   cd $pkgname
23   ./autogen.sh
26 build() {
27   cd $pkgname
28   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
29     --disable-static --libexecdir=/usr/lib
30   make
33 check() {
34   cd $pkgname
35   make check
38 package() {
39   cd $pkgname
40   make DESTDIR="$pkgdir" install