upgpkg: sbcl 2.2.11-1
[arch-packages.git] / qt6-positioning / trunk / PKGBUILD
blob5ce1c42f2b834c9f1857a1a245030db3af1e707b
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-positioning
5 _qtver=6.4.1
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides access to position, satellite and area monitoring classes'
12 depends=(qt6-base)
13 makedepends=(cmake ninja qt6-declarative qt6-serialport)
14 optdepends=('qt6-declarative: QML bindings' 'qt6-serialport: NMEA plugin')
15 conflicts=(qt6-location)
16 provides=(qt6-location)
17 replaces=(qt6-location)
18 groups=(qt6)
19 options=(debug)
20 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
21 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
22 sha256sums=('706112e81cd938512f985ffabf6e8a9be971f722864a94b11b9d71ccd5b8d18b')
24 build() {
25   cmake -B build -S $_pkgfn -G Ninja \
26     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build
33   install -d "$pkgdir"/usr/share/licenses
34   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname