upgpkg: sbcl 2.2.11-1
[arch-packages.git] / vala / trunk / PKGBUILD
blob6bdc0fbfad433218d47eab11f0ff7a1790aa22dc
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 # Contributor: Timm Preetz <timm@preetz.us>
6 pkgname=vala
7 pkgver=0.56.3
8 pkgrel=1
9 pkgdesc='Compiler for the GObject type system'
10 url='https://wiki.gnome.org/Projects/Vala'
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(glib2 gtk-doc graphviz ttf-font pkg-config gcc)
14 makedepends=(libxslt vala git help2man autoconf-archive)
15 checkdepends=(dbus libx11 gobject-introspection)
16 provides=(valadoc libvala-${pkgver%.*}.so libvaladoc-${pkgver%.*}.so)
17 conflicts=(valadoc)
18 replaces=(valadoc)
19 options=(debug)
20 _commit=051552f34cfa1f4c08220043683289952f9ffd62  # tags/0.56.3^0
21 source=("git+https://gitlab.gnome.org/GNOME/vala.git#commit=$_commit")
22 sha256sums=('SKIP')
24 pkgver() {
25   cd vala
26   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 prepare() {
30   cd vala
31   NOCONFIGURE=1 ./autogen.sh
34 build() {
35   cd vala
36   ./configure --prefix=/usr
37   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
38   make
41 check() {
42   cd vala
43   make check
46 package() {
47   cd vala
48   make DESTDIR="$pkgdir" install
51 # vim:set sw=2 et: