Update README.md
[aurutils.git] / makepkg / PKGBUILD
blob5567a26fba682359b2ded582c47eb14a69ab8bfc
1 # Maintainer: Alad Wenter <https://github.com/AladW>
2 pkgname=aurutils-git
3 pkgver=8.1.1.r1.gb2d35fc
4 pkgrel=1
5 pkgdesc='helper tools for the arch user repository'
6 url='https://github.com/AladW/aurutils'
7 arch=('any')
8 license=('custom:ISC')
9 source=('git+https://github.com/AladW/aurutils')
10 changelog=aurutils.changelog
11 sha256sums=('SKIP')
12 conflicts=('aurutils')
13 provides=("aurutils=${pkgver%%.r*}")
14 depends=('git' 'jq' 'pacutils' 'curl' 'expect')
15 makedepends=('git')
16 optdepends=('bash-completion: bash completion'
17             'zsh: zsh completion'
18             'devtools: aur-chroot'
19             'vifm: default pager'
20             'ninja: aur-sync ninja support')
22 pkgver() {
23     cd aurutils
24     git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
27 build() {
28     cd aurutils
29     make
32 package() {
33     cd aurutils
34     make DESTDIR="$pkgdir" install