3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
16 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
19 DESTDIR
= $(CURDIR
)/debian
/awish-bld
22 #ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
29 ifneq (,$(findstring sound
,$(DEB_BUILD_OPTIONS
)))
30 FORCE_SOUND
= --force-sound
35 ifneq (,$(findstring thumb
,$(DEB_BUILD_OPTIONS
)))
36 GNU89INLINE
= MAEMO47
=1 USE_THUMB
=1
39 ifneq (,$(findstring k8maemo47
,$(DEB_BUILD_OPTIONS
)))
40 GNU89INLINE
= MAEMO47
=1
48 configure
: configure-stamp
51 jam configure
--prefix=/usr
--install-awasm
--install-vmsrc
$(FORCE_SOUND
)
56 build-stamp
: configure-stamp
58 # Add here commands to configure the package.
59 jam
-a
$(GNU89INLINE
) $(PROF
)
66 rm -f configure-stamp build-stamp
68 # Add here commands to clean up after the build process.
69 rm -f build-stamp configure-stamp || true
71 rm -rf
$(DESTDIR
) || true
72 rm -rf
$(CURDIR
)/debian
/awish || true
73 rm -rf
$(CURDIR
)/debian
/awish-data || true
74 rm -rf
$(CURDIR
)/debian
/awish-vm-source || true
84 # Add here commands to install the package into $(DESTDIR)
85 DESTDIR
=$(DESTDIR
) jam
install
88 # Build architecture-independent files here.
89 binary-indep
: build
install
90 # We have nothing to do by default.
92 # Build architecture-dependent files here.
93 binary-arch
: build
install
102 # dh_installlogrotate
124 binary
: binary-indep binary-arch
125 .PHONY
: build
clean binary-indep binary-arch binary
install