- u9fs: upstream is dead
[booboo.git] / sys-fs / gmailfs / gmailfs-0.8.0.ebuild
blob2ae679b5dba69cce0b80a8b4b86f92c62aaf6570
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4 # This ebuild come from http://bugs.gentoo.org/show_bug.cgi?id=63785 - The site http://gentoo.zugaina.org/ only host a copy.
6 inherit eutils
8 KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
9 DESCRIPTION="GmailFS provides a mountable Linux filesystem which uses your Gmail account as its storage medium."
10 HOMEPAGE="http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html"
11 SRC_URI="http://richard.jones.name/google-hacks/gmail-filesystem/${P}.tar.gz"
12 RESTRICT="nomirror"
13 LICENSE="GPL-2"
14 SLOT="0"
15 IUSE=""
17 RDEPEND=">=dev-lang/python-2.3
18 >=dev-python/fuse-python-0.1
19 >=sys-fs/fuse-1.3
20 >=net-libs/libgmail-0.1.3.3
21 dev-python/fuse-python"
23 src_unpack() {
24 unpack ${A}
25 cd ${WORKDIR}
28 src_install() {
29 dobin ${WORKDIR}/${P}/gmailfs.py || die "Can't dobin"
30 insinto /sbin
31 doins ${WORKDIR}/${P}/mount.gmailfs || die "Can't write to /sbin"
32 insinto /etc
33 doins ${WORKDIR}/${P}/gmailfs.conf || die "Can't write to /etc"
34 dodoc README* ChangeLog
37 pkg_postinst() {
38 einfo "You should now be able to mount gmailfs."
39 einfo "To mount from the command line, do:"
40 einfo "mount -t gmailfs /usr/bin/gmailfs.py /path/of/mount/point -o username=gmailuser,password=gmailpass,fsname=zOlRRa"
41 einfo "To use fstab, create an entry /etc/fstab that looks something like:"
42 einfo "/usr/bin/gmailfs.py /path/of/mount/point gmailfs noauto,username=gmailuser,password=gmailpass,fsname=zOlRRa"
43 einfo " "
44 ewarn "Remember to choose a very creative, unguessable fsname, else someone"
45 ewarn "could manipulate your filesystem. Also remember that gmailfs is a"
46 ewarn "cruel hack. So don't expect things like good performance"
47 einfo " "
48 einfo "You actually need to use libgmail from CVS. So do this:"
49 einfo "cvs -d:pserver:anonymous@cvs.sourceforge.net:/cvsroot/libgmail login"
50 einfo "cvs -d:pserver:anonymous@cvs.sourceforge.net:/cvsroot/libgmail co libgmail"
51 einfo "then copy constants.py and libgmail.py to your"
52 einfo "/usr/lib/python-<ver>/site-packages directory"
53 chmod a+x /sbin/mount.gmailfs