1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 CMAKE_IN_SOURCE_BUILD
=1
7 inherit eutils cmake-utils gnome2-utils versionator multilib git-r3
9 DESCRIPTION
="Open source clone of Theme Hospital"
10 HOMEPAGE
="https://github.com/CorsixTH/CorsixTH"
11 EGIT_REPO_URI
="https://github.com/CorsixTH/CorsixTH"
16 IUSE
="-libav midi +sound truetype"
18 RDEPEND
=">=dev-lang/lua-5.1:0
19 media-libs/libsdl2[X,opengl]
24 midi? ( media-sound/timidity++ )
25 !libav? ( media-video/ffmpeg:0= )
26 libav? ( media-video/libav:0= )
27 sound? ( media-libs/sdl2-mixer )
28 truetype? ( media-libs/freetype:2 )"
34 $
(cmake-utils_use_with sound AUDIO
)
35 $
(cmake-utils_use_with truetype FREETYPE2
)
36 $
(cmake-utils_use_with libav LIBAV
)
37 -DCMAKE_INSTALL_PREFIX=/usr
/share
/games
40 cmake-utils_src_configure
44 cmake-utils_src_compile
48 DOCS
="CorsixTH/changelog.txt" cmake-utils_src_install
49 newicon
-s scalable CorsixTH
/Original_Logo.svg
"${PN}.svg"
50 make_wrapper
"${PN}" /usr
/share
/games
/CorsixTH
/CorsixTH
51 make_desktop_entry
"${PN}"
59 gnome2_icon_cache_update
63 gnome2_icon_cache_update