1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools linux-info
8 DESCRIPTION
="Miredo is an open-source Teredo IPv6 tunneling software"
9 HOMEPAGE
="http://www.remlab.net/miredo/"
10 SRC_URI
="http://www.remlab.net/files/${PN}/${P}.tar.xz"
17 RDEPEND
="sys-apps/iproute2
19 caps? ( sys-libs/libcap )
25 CONFIG_CHECK
="~IPV6" #318777
27 #tries to connect to external networks (#339180)
30 DOCS
=( AUTHORS ChangeLog NEWS README TODO THANKS
)
33 eapply
"${FILESDIR}"/${PN}-1.2
.5-configure-libcap.
diff
34 eapply
"${FILESDIR}"/${PN}-1.2
.5-ip-path.
patch
42 --enable-miredo-user \
43 --localstatedir=/var \
44 $
(use_with caps libcap
)
49 find "${ED}" -name '*.la' -delete || die
51 newinitd
"${FILESDIR}"/miredo.rc
.2 miredo
52 newconfd
"${FILESDIR}"/miredo.conf
.2 miredo
53 newinitd
"${FILESDIR}"/miredo.rc
.2 miredo-server
54 newconfd
"${FILESDIR}"/miredo.conf
.2 miredo-server
57 doins misc
/miredo-server.conf