wide-dhcpv6: correct installed files uid/gid
[booboo.git] / net-misc / wide-dhcpv6 / wide-dhcpv6-20080615-r2.ebuild
blob742260a5d53daff8c0fa1fd2e8972c8ac08a8de6
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # Written by Takeshi KIRIYA (aka takeshik) <me@takeshik.org>.
5 EAPI=5
7 inherit flag-o-matic
9 DESCRIPTION="DHCP Client and Server originally developed by KAME Project"
10 HOMEPAGE="http://wide-dhcpv6.sourceforge.net/"
11 SRC_URI="http://downloads.sourceforge.net/project/wide-dhcpv6/wide-dhcpv6/wide-dhcpv6-20080615/wide-dhcpv6-20080615.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="vanilla"
18 DEPEND=""
19 RDEPEND="${DEPEND}"
21 src_configure() {
22 rm cfparse.c cftoken.c # generated file
23 epatch "${FILESDIR}/fix-libc-depend.patch"
24 epatch "${FILESDIR}/fix-dprintf-conflict.patch"
25 epatch "${FILESDIR}/address-suffix-1.patch"
26 epatch "$FILESDIR/0002-Don-t-strip-binaries.patch"
27 use vanilla || {
28 epatch "$FILESDIR/0005-Update-ifid-on-interface-restart.patch"
29 epatch "$FILESDIR/0006-Add-new-feature-dhcp6c-profiles.patch"
30 epatch "$FILESDIR/0007-Adding-ifid-option-to-the-dhcp6c.conf-prefix-interfa.patch"
31 epatch "$FILESDIR/0015-a-bit-info-to-logger-when-get-OPTION_RECONF_ACCEPT.patch"
32 epatch "$FILESDIR/wide-dhcpv6-disable-extra-cflags.patch"
35 # defaults to `bin`
36 econf --with-user=root --with-group=root
39 src_compile() {
40 emake -j1
43 mkd() {
44 local x=$1 X=$2 i=$3
45 sed \
46 -e "s:6x:6${x}:g" \
47 -e "s:6X:6${X}:g" \
48 "${FILESDIR}"/dhcp6x.${i}d.in > dhcp6${x}.${i}d
49 new${i}d dhcp6${x}.${i}d dhcp6${x}
52 src_install() {
53 einstall DESTDIR="${D}" || die
54 mkd c R init
55 mkd c R conf
56 mkd r R init
57 mkd r R conf
58 mkd s S init
59 mkd s S conf
60 insinto /etc/wide-dhcpv6
61 newins dhcp6c.conf.sample dhcp6c.conf
62 newins dhcp6s.conf.sample dhcp6s.conf