qcad: install default block and template libraries
[booboo.git] / sci-electronics / qucs / qucs-0.0.19.ebuild
blob6db081c15744c4293b344c5e8866040ebe78fa44
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=7
7 inherit flag-o-matic toolchain-funcs
9 DESCRIPTION="Quite Universal Circuit Simulator in Qt4"
10 HOMEPAGE="http://qucs.sourceforge.net/"
11 fn="${PN}-$PV"
12 SRC_URI="mirror://sourceforge/${PN}/${fn}.tar.gz"
13 S="$WORKDIR/$fn"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
20 RDEPEND="dev-qt/qtcore:4[qt3support]
21 dev-qt/qtgui:4[qt3support]
22 dev-qt/qtsvg:4
23 dev-qt/qt3support:4
24 x11-libs/libX11
25 sci-electronics/adms"
26 DEPEND="${RDEPEND}
27 doc? ( sci-mathematics/octave )"
29 AUTOTOOLS_IN_SOURCE_BUILD=1
31 # picks proper moc
32 export QT_SELECT=qt4
34 # picks clang++ otherwise for some strange reason
35 export CXX=g++
37 src_configure() {
38 # the package doesn't use pkg-config on Linux, only on Darwin
39 # very smart of upstream...
40 append-ldflags $( $(tc-getPKG_CONFIG) --libs-only-L \
41 QtCore QtGui QtXml Qt3Support )
43 econf $(use_enable doc) # https://github.com/Qucs/qucs/issues/582
45 autotools-utils_src_configure