1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
7 inherit flag-o-matic toolchain-funcs
9 DESCRIPTION
="Quite Universal Circuit Simulator in Qt4"
10 HOMEPAGE
="http://qucs.sourceforge.net/"
12 SRC_URI
="mirror://sourceforge/${PN}/${fn}.tar.gz"
17 KEYWORDS
="~amd64 ~x86"
20 RDEPEND
="dev-qt/qtcore:4[qt3support]
21 dev-qt/qtgui:4[qt3support]
27 doc? ( sci-mathematics/octave )"
29 AUTOTOOLS_IN_SOURCE_BUILD
=1
34 # picks clang++ otherwise for some strange reason
38 # the package doesn't use pkg-config on Linux, only on Darwin
39 # very smart of upstream...
40 append-ldflags $
( $
(tc-getPKG_CONFIG
) --libs-only-L \
41 QtCore QtGui QtXml Qt3Support
)
43 econf $
(use_enable doc
) # https://github.com/Qucs/qucs/issues/582
45 autotools-utils_src_configure