mozconfig-v6.52.eclass: no users, removing
[booboo.git] / media-sound / ayfly / ayfly-9999.ebuild
blobdc069d0d7cc1a1f043f9cd55c5553c72d5e925d4
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 EAPI=8
5 inherit git-r3 autotools
7 DESCRIPTION="Ayfly is a AY-891x emulator and player."
8 HOMEPAGE="https://github.com/l29ah/ayfly"
9 EGIT_REPO_URI="https://github.com/l29ah/ayfly"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64 ~arm"
14 IUSE="wxwidgets"
16 RDEPEND="wxwidgets? ( x11-libs/wxGTK )"
17 DEPEND="$RDEPEND
18 media-libs/libsdl
19 sys-devel/automake"
22 src_prepare() {
23 default
24 use arm && epatch ${FILESDIR}/disable_filters.patch
25 eautoreconf
28 src_configure() {
29 local myconf
30 use wxwidgets || myconf+=" --without-gui"
31 econf $myconf