1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
7 PYTHON_COMPAT=( python3_{10..13} )
9 inherit autotools gnome2-utils lua-single python-any-r1 xdg git-r3
11 DESCRIPTION="Modification of the classical Freedroid engine into an RPG"
12 HOMEPAGE="https://www.freedroid.org"
14 EGIT_REPO_URI="https://gitlab.com/freedroid/freedroid-src.git"
19 IUSE="debug devtools nls opengl profile sanitize +sound"
20 REQUIRED_USE="${LUA_REQUIRED_USE}"
25 media-libs/libsdl[opengl?,sound?,video]
26 >=media-libs/sdl-gfx-2.0.21:=
27 media-libs/sdl-image[jpeg,png]
29 devtools? ( media-libs/sdl-ttf )
30 nls? ( virtual/libintl )
38 media-libs/sdl-mixer[vorbis]
44 nls? ( sys-devel/gettext )
45 sanitize? ( || ( sys-devel/gcc[sanitize] sys-devel/clang-runtime[sanitize] ) )"
47 S="${WORKDIR}/${PN}-${PV}"
51 python-any-r1_pkg_setup
57 python_fix_shebang src/gen_savestruct.py
58 rm data/sound/speak.py || die # unused, prevent installing
65 $(use_enable debug backtrace)
67 $(use_enable devtools dev-tools)
70 $(use_enable profile rtprof)
72 $(use_with debug extra-warnings)
73 $(use_enable sanitize sanitize-address)
75 econf "${econfargs[@]}"
81 if [[ ${REPLACING_VERSIONS} ]]; then
83 if ver_test ${REPLACING_VERSIONS} -lt ${min}; then
84 elog "${P} is not compatible with save games before ${min}."
85 elog "Please start a new character."