1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT=( python3_{3..13} )
8 inherit git-r3 cmake python-single-r1
10 DESCRIPTION="CAD from a parallel universe"
11 HOMEPAGE="http://www.mattkeeter.com/projects/antimony/3/"
12 EGIT_REPO_URI="https://github.com/mkeeter/antimony.git"
17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
19 # https://github.com/mkeeter/antimony/issues/196
21 >dev-util/lemon-3.8.11 <dev-util/lemon-3.24.0
23 dev-libs/boost:=[python]
31 python-single-r1_pkg_setup
35 # stumbles upon the highest installed python version otherwise
36 sed -i -e "s/Python 3\.3 /Python ${EPYTHON/python/} EXACT /" CMakeLists.txt