removed broken orphaned ebuilds
[booboo.git] / media-gfx / qiv / qiv-9999.ebuild
blob1b5db858e348e32a80dcb70a37194f55624c34f8
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 inherit toolchain-funcs git-r3
7 DESCRIPTION="Quick Image Viewer"
8 HOMEPAGE="http://spiegl.de/qiv/"
9 EGIT_REPO_URI='https://codeberg.org/ciberandy/qiv'
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS=""
14 IUSE="xinerama"
16 RDEPEND="x11-libs/gtk+:2
17         media-libs/imlib2
18         media-libs/libexif
19         xinerama? ( x11-libs/libXinerama )"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
23 src_prepare() {
24         sed -i \
25                 -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' \
26                 Makefile || die
28         if ! use xinerama; then
29                 sed -i \
30                         -e 's:-DGTD_XINERAMA::' \
31                         Makefile || die
32         fi
33         default
36 src_compile() {
37         emake CC="$(tc-getCC)" || die
40 src_install() {
41         dobin qiv || die
42         doman qiv.1
43         dodoc Changelog README README.TODO