1 #Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
7 DESCRIPTION
="Iptables frontend. Ncurses GUI, for administration and monitoring."
8 HOMEPAGE
="http://www.vuurmuur.org"
9 SRC_URI
="mirror://sourceforge/vuurmuur/${MY_PKG_NAME}-${PV}.tar.gz"
17 RDEPEND
="net-firewall/iptables
18 =net-libs/libvuurmuur-${PV}
19 =net-firewall/vuurmuur-${PV}
24 unpack
${A} || die
"Unpacking of ${A} did not succeed"
25 cd ${MY_PKG_NAME}-${PV} || die "Changing to the ${MY_PKG_NAME}-${PV} directory failed
"
27 # Because we need to unpack something from the just unpacked file, we do it
28 # like a shell command
29 einfo "Unpacking
${P}.
tar.gz
"
30 gzip -cd ${P}.tar.gz | tar xf - || die "Unpacking of
${P}.
tar.gz failed
"
31 #unpack ${P}.tar.gz || die "Unpacking of
${P}.
tar.gz failed
"
38 cd ${WORKDIR}/${MY_PKG_NAME}-${PV}/${P} || die
44 econf --with-libvuurmuur-includes=/usr/include \
45 --with-libvuurmuur-libraries=/usr/lib \
46 --with-localedir=/usr/share/locale \
48 || die "The configure
script failed
"
49 emake || die "Making did not succeed
"
55 cd ${WORKDIR}/${MY_PKG_NAME}-${PV}/${P} || die "Could not change
dirs"