app-text/sdcv: version bump, from ::gentoo
[booboo.git] / net-misc / vuurmuur_conf / vuurmuur_conf-0.7.ebuild
blob75324a5a66174da181fffc4289181c906b1d670d
1 #Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4 # Made by Tiger!P
6 MY_PKG_NAME="Vuurmuur"
7 DESCRIPTION="Iptables frontend. Ncurses GUI, for administration and monitoring."
8 HOMEPAGE="http://www.vuurmuur.org"
9 SRC_URI="mirror://sourceforge/vuurmuur/${MY_PKG_NAME}-${PV}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~ppc"
14 IUSE=""
16 DEPEND=""
17 RDEPEND="net-firewall/iptables
18 =net-libs/libvuurmuur-${PV}
19 =net-firewall/vuurmuur-${PV}
20 >=sys-libs/ncurses-5"
22 src_unpack()
24 unpack ${A} || die "Unpacking of ${A} did not succeed"
25 cd ${MY_PKG_NAME}-${PV} || die "Changing to the ${MY_PKG_NAME}-${PV} directory failed"
26 #einfo "pwd: ${PWD}"
27 # Because we need to unpack something from the just unpacked file, we do it
28 # like a shell command
29 einfo "Unpacking ${P}.tar.gz"
30 gzip -cd ${P}.tar.gz | tar xf - || die "Unpacking of ${P}.tar.gz failed"
31 #unpack ${P}.tar.gz || die "Unpacking of ${P}.tar.gz failed"
32 #einfo "pwd: ${PWD}"
35 src_compile()
37 #einfo "pwd: ${PWD}"
38 cd ${WORKDIR}/${MY_PKG_NAME}-${PV}/${P} || die
39 libtoolize -f
40 aclocal
41 autoheader
42 automake
43 autoconf
44 econf --with-libvuurmuur-includes=/usr/include \
45 --with-libvuurmuur-libraries=/usr/lib \
46 --with-localedir=/usr/share/locale \
47 --with-widec=yes \
48 || die "The configure script failed"
49 emake || die "Making did not succeed"
52 src_install()
54 #einfo "pwd: ${PWD}"
55 cd ${WORKDIR}/${MY_PKG_NAME}-${PV}/${P} || die "Could not change dirs"
56 einstall