fs/ubifs: work around fakeroot / sed -i issue on systems with SELinux enabled
[buildroot-gz.git] / package / pseudo / pseudo.mk
blobaa2a9c78a07916a675c75869c647ff3e7651a3ec
1 ################################################################################
3 # pseudo
5 ################################################################################
7 PSEUDO_VERSION = 45eca34c754d416a38bee90fb2d3c110a0b6cc5f
8 PSEUDO_SITE = https://git.yoctoproject.org/git/pseudo
9 PSEUDO_SITE_METHOD = git
11 # No "or later" clause.
12 PSEUDO_LICENSE = LGPLv2.1
13 PSEUDO_LICENSE_FILES = COPYING
15 HOST_PSEUDO_DEPENDENCIES = host-attr host-sqlite
17 # configure script is not generated by autoconf, so passing --libdir
18 # is necessary, even if the infrastructure passes --prefix already.
19 # It also does not use CFLAGS from the environment, they need to be
20 # specified with a custom --cflags option. Also force rpath to avoid
21 # a warning at configure time.
22 HOST_PSEUDO_CONF_OPTS = \
23 --cflags="$(HOSTCFLAGS)" \
24 --with-rpath=$(HOST_DIR)/usr/lib \
25 --bits=$(if $(filter %64,$(HOSTARCH)),64,32) \
26 --libdir=$(HOST_DIR)/usr/lib \
27 --with-sqlite=$(HOST_DIR)/usr
29 define HOST_PSEUDO_INSTALL_WRAPPER
30 $(INSTALL) -D -m 0755 $(HOST_PSEUDO_PKGDIR)/pseudo-wrapper \
31 $(HOST_DIR)/usr/bin/pseudo-wrapper
32 endef
33 HOST_PSEUDO_POST_INSTALL_HOOKS += HOST_PSEUDO_INSTALL_WRAPPER
35 define HOST_PSEUDO_FAKEROOT_SYMLINK
36 ln -sf pseudo-wrapper $(HOST_DIR)/usr/bin/fakeroot
37 endef
38 HOST_PSEUDO_POST_INSTALL_HOOKS += HOST_PSEUDO_FAKEROOT_SYMLINK
40 $(eval $(host-autotools-package))