1 ################################################################################
5 ################################################################################
7 OPEN_PLC_UTILS_VERSION
= 1be781d1ea81827e5f6c1a35961c65dd4d15472c
8 OPEN_PLC_UTILS_SITE
= $(call github
,qca
,open-plc-utils
,$(OPEN_PLC_UTILS_VERSION
))
9 OPEN_PLC_UTILS_LICENSE
= BSD-3c
10 OPEN_PLC_UTILS_LICENSE_FILES
= LICENSE
12 # We unfortunately can't use TARGET_CONFIGURE_OPTS, as it would
13 # override the package CFLAGS, LDFLAGS and CXXFLAGS definitions.
15 # Yes, we're passing __UCLIBC__ in EXTRA_CFLAGS, as it fixes a build
16 # issue for non-uClibc toolchains. It is the very crappy solution
17 # suggested at https://github.com/qca/open-plc-utils/issues/36.
18 define OPEN_PLC_UTILS_BUILD_CMDS
19 $(TARGET_MAKE_ENV
) $(MAKE
) CROSS
=$(TARGET_CROSS
) EXTRA_CFLAGS
="-D__UCLIBC__" -C
$(@D
)
22 define OPEN_PLC_UTILS_INSTALL_TARGET_CMDS
23 $(TARGET_MAKE_ENV
) $(MAKE
) ROOTFS
=$(TARGET_DIR
) -C
$(@D
) install
26 $(eval
$(generic-package
))