package/x11r7/xdriver_xf86-video-siliconmotion: bump version to 1.7.9
[buildroot-gz.git] / package / openipmi / openipmi.mk
blob9faa7c685f89b04e5e52a7800c1afec6e8061188
1 ################################################################################
3 # openipmi
5 ################################################################################
7 OPENIPMI_VERSION = 2.0.22
8 OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library
9 OPENIPMI_SOURCE = OpenIPMI-$(OPENIPMI_VERSION).tar.gz
10 OPENIPMI_PATCH = \
11 http://sourceforge.net/p/openipmi/patches/26/attachment/0001-ui-use-standard-uint32_t.patch
12 OPENIPMI_LICENSE = LGPLv2+, GPLv2+, BSD-3c
13 OPENIPMI_LICENSE_FILES = COPYING.LIB COPYING COPYING.BSD
14 OPENIPMI_DEPENDENCIES = popt ncurses host-pkgconf
15 # Patching Makefile.am
16 OPENIPMI_AUTORECONF = YES
17 OPENIPMI_CONF_ENV = ac_cv_path_pkgprog="$(PKG_CONFIG_HOST_BINARY)"
18 OPENIPMI_CONF_OPTS = \
19 --with-glib=no \
20 --with-glib12=no \
21 --with-tcl=no \
22 --with-perl=no \
23 --with-python=no \
24 --with-swig=no
26 ifeq ($(BR2_PACKAGE_GDBM),y)
27 OPENIPMI_DEPENDENCIES += gdbm
28 endif
30 ifeq ($(BR2_PACKAGE_OPENSSL),y)
31 OPENIPMI_DEPENDENCIES += openssl
32 OPENIPMI_CONF_OPTS += --with-openssl=yes
33 else
34 OPENIPMI_CONF_OPTS += --with-openssl=no
35 endif
37 ifeq ($(BR2_PACKAGE_NETSNMP),y)
38 OPENIPMI_DEPENDENCIES += netsnmp
39 OPENIPMI_CONF_OPTS += --with-ucdsnmp=yes
40 else
41 OPENIPMI_CONF_OPTS += --with-ucdsnmp=no
42 endif
44 $(eval $(autotools-package))