package/x11r7/xdriver_xf86-video-siliconmotion: bump version to 1.7.9
[buildroot-gz.git] / package / python-serial / python-serial.mk
blob4b3ffadc1c581446a405702e11439eadf5c0582b
1 ################################################################################
3 # python-serial
5 ################################################################################
7 PYTHON_SERIAL_VERSION = 3.1
8 PYTHON_SERIAL_SOURCE = pyserial-$(PYTHON_SERIAL_VERSION).tar.gz
9 PYTHON_SERIAL_SITE = https://pypi.python.org/packages/ce/9c/694ce79a9d4a164e109aeba1a40fba23336f3b7554978553e22a5d41d54d
10 PYTHON_SERIAL_LICENSE = Python Software Foundation License
11 PYTHON_SERIAL_LICENSE_FILES = LICENSE.txt
12 PYTHON_SERIAL_SETUP_TYPE = setuptools
14 # aio.py is an experimental module, that is compatible only with
15 # Python 3, so remove it for Python 2 environment or it will
16 # cause compilation errors
17 ifeq ($(BR2_PACKAGE_PYTHON),y)
18 define PYTHON_SERIAL_REMOVE_AIO_PY
19 rm $(@D)/serial/aio.py
20 endef
21 PYTHON_SERIAL_POST_EXTRACT_HOOKS = PYTHON_SERIAL_REMOVE_AIO_PY
22 endif
24 $(eval $(python-package))