package/aubio: add libsndfile optional dependency
[buildroot-gz.git] / package / dosfstools / dosfstools.mk
blob67c6f731031982d8af27dd16a1c8fc3745df22de
1 ################################################################################
3 # dosfstools
5 ################################################################################
7 DOSFSTOOLS_VERSION = 4.0
8 DOSFSTOOLS_SOURCE = dosfstools-$(DOSFSTOOLS_VERSION).tar.xz
9 DOSFSTOOLS_SITE = https://github.com/dosfstools/dosfstools/releases/download/v$(DOSFSTOOLS_VERSION)
10 DOSFSTOOLS_LICENSE = GPLv3+
11 DOSFSTOOLS_LICENSE_FILES = COPYING
12 DOSFSTOOLS_CONF_OPTS = --enable-compat-symlinks --exec-prefix=/
13 HOST_DOSFSTOOLS_CONF_OPTS = --enable-compat-symlinks
15 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
16 DOSFSTOOLS_CONF_OPTS += --with-udev
17 DOSFSTOOLS_DEPENDENCIES += udev
18 else
19 DOSFSTOOLS_CONF_OPTS += --without-udev
20 endif
22 ifneq ($(BR2_ENABLE_LOCALE),y)
23 DOSFSTOOLS_CONF_OPTS += LIBS="-liconv"
24 DOSFSTOOLS_DEPENDENCIES += libiconv
25 endif
27 ifeq ($(BR2_PACKAGE_DOSFSTOOLS_FATLABEL),)
28 define DOSFSTOOLS_REMOVE_FATLABEL
29 rm -f $(addprefix $(TARGET_DIR)/sbin/,dosfslabel fatlabel)
30 endef
31 DOSFSTOOLS_POST_INSTALL_TARGET_HOOKS += DOSFSTOOLS_REMOVE_FATLABEL
32 endif
34 ifeq ($(BR2_PACKAGE_DOSFSTOOLS_FSCK_FAT),)
35 define DOSFSTOOLS_REMOVE_FSCK_FAT
36 rm -f $(addprefix $(TARGET_DIR)/sbin/,fsck.fat dosfsck fsck.msdos fsck.vfat)
37 endef
38 DOSFSTOOLS_POST_INSTALL_TARGET_HOOKS += DOSFSTOOLS_REMOVE_FSCK_FAT
39 endif
41 ifeq ($(BR2_PACKAGE_DOSFSTOOLS_MKFS_FAT),)
42 define DOSFSTOOLS_REMOVE_MKFS_FAT
43 rm -f $(addprefix $(TARGET_DIR)/sbin/,mkfs.fat mkdosfs mkfs.msdos mkfs.vfat)
44 endef
45 DOSFSTOOLS_POST_INSTALL_TARGET_HOOKS += DOSFSTOOLS_REMOVE_MKFS_FAT
46 endif
48 $(eval $(autotools-package))
49 $(eval $(host-autotools-package))