iptables: bump to version 1.6.1
[buildroot-gz.git] / package / heimdal / heimdal.mk
bloba20ec8f9da38fa2fb58e57b816795914824d6f34
1 ################################################################################
3 # heimdal
5 ################################################################################
7 HEIMDAL_VERSION = 7.1.0
8 HEIMDAL_SITE = http://www.h5l.org/dist/src
9 HOST_HEIMDAL_DEPENDENCIES = host-e2fsprogs host-ncurses host-pkgconf
10 HEIMDAL_INSTALL_STAGING = YES
11 # static because of -fPIC issues with e2fsprogs on x86_64 host
12 HOST_HEIMDAL_CONF_OPTS = \
13 --disable-shared \
14 --enable-static \
15 --without-openldap \
16 --without-capng \
17 --without-sqlite3 \
18 --without-libintl \
19 --without-openssl \
20 --without-berkeley-db \
21 --without-readline \
22 --without-libedit \
23 --without-hesiod \
24 --without-x \
25 --disable-heimdal-documentation
26 HOST_HEIMDAL_CONF_ENV = MAKEINFO=true
27 HEIMDAL_LICENSE = BSD-3c
28 HEIMDAL_LICENSE_FILES = LICENSE
30 # We need asn1_compile in the PATH for samba4
31 define HOST_HEIMDAL_MAKE_SYMLINK
32 ln -sf $(HOST_DIR)/usr/libexec/heimdal/asn1_compile \
33 $(HOST_DIR)/usr/bin/asn1_compile
34 ln -sf $(HOST_DIR)/usr/bin/compile_et \
35 $(HOST_DIR)/usr/libexec/heimdal/compile_et
36 endef
38 HOST_HEIMDAL_POST_INSTALL_HOOKS += HOST_HEIMDAL_MAKE_SYMLINK
40 $(eval $(host-autotools-package))