1 ################################################################################
5 ################################################################################
8 OLA_SITE
= https
://github.com
/OpenLightingProject
/ola
/releases
/download
/$(OLA_VERSION
)
9 OLA_LICENSE
= LGPLv2.1
+ (libola
, libolacommon
, Python bindings
), GPLv2
+ (libolaserver
, olad
, Python examples and tests
)
10 OLA_LICENSE_FILES
= LICENCE GPL LGPL
11 OLA_INSTALL_STAGING
= YES
14 # util-linux provides uuid lib
15 OLA_DEPENDENCIES
= protobuf util-linux host-bison host-flex host-ola
18 ac_cv_have_pymod_google_protobuf
=yes \
22 --disable-root-check \
24 --disable-fatal-warnings \
25 --with-ola-protoc-plugin
=$(HOST_DIR
)/usr
/bin
/ola_protoc_plugin
27 HOST_OLA_DEPENDENCIES
= host-util-linux host-protobuf
29 # When building the host part, disable as much as possible to speed up
30 # the configure step and avoid missing host dependencies.
31 HOST_OLA_CONF_OPTS
= \
32 --disable-all-plugins \
41 --disable-doxygen-html \
42 --disable-doxygen-doc \
43 --disable-fatal-warnings
45 # On the host side, we only need ola_protoc_plugin, so build and install this
47 HOST_OLA_MAKE_OPTS
= protoc
/ola_protoc_plugin
48 define HOST_OLA_INSTALL_CMDS
49 $(INSTALL
) -D
-m
0755 $(@D
)/protoc
/ola_protoc_plugin
$(HOST_DIR
)/usr
/bin
/ola_protoc_plugin
52 # sets where to find python libs built for target and required by ola
53 OLA_CONF_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
54 OLA_MAKE_ENV
= PYTHONPATH
=$(TARGET_DIR
)/usr
/lib
/python
$(PYTHON_VERSION_MAJOR
)/site-packages
56 ## OLA Bindings and Interface selections
58 ifeq ($(BR2_PACKAGE_OLA_WEB
),y
)
59 OLA_CONF_OPTS
+= --enable-http
60 OLA_DEPENDENCIES
+= libmicrohttpd
62 OLA_CONF_OPTS
+= --disable-http
65 ifeq ($(BR2_PACKAGE_OLA_SLP
),y
)
66 OLA_CONF_OPTS
+= --enable-slp
68 OLA_CONF_OPTS
+= --disable-slp
71 ifeq ($(BR2_PACKAGE_OLA_PYTHON_BINDINGS
),y
)
72 OLA_CONF_OPTS
+= --enable-python-libs
73 OLA_DEPENDENCIES
+= python python-protobuf
75 OLA_CONF_OPTS
+= --disable-python-libs
78 ## OLA Examples and Tests
80 ifeq ($(BR2_PACKAGE_OLA_EXAMPLES
),y
)
81 OLA_CONF_OPTS
+= --enable-examples
82 OLA_DEPENDENCIES
+= ncurses
84 OLA_CONF_OPTS
+= --disable-examples
87 ifeq ($(BR2_PACKAGE_OLA_RDM_TESTS
),y
)
88 OLA_CONF_OPTS
+= --enable-rdm-tests
89 OLA_DEPENDENCIES
+= python-numpy
90 # needed as numpy builds some shared libraries and ola checks for
91 # numpy using a host python test program which fails with 'wrong ELF
93 OLA_CONF_ENV
= ac_cv_have_pymod_numpy
=yes
95 OLA_CONF_OPTS
+= --disable-rdm-tests
98 ## OLA Plugin selections
100 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_E131
),y
)
101 OLA_CONF_OPTS
+= --enable-e131
103 OLA_CONF_OPTS
+= --disable-e131
106 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ARTNET
),y
)
107 OLA_CONF_OPTS
+= --enable-artnet
109 OLA_CONF_OPTS
+= --disable-artnet
112 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OPENDMX
),y
)
113 OLA_CONF_OPTS
+= --enable-opendmx
115 OLA_CONF_OPTS
+= --disable-opendmx
118 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_DUMMY
),y
)
119 OLA_CONF_OPTS
+= --enable-dummy
121 OLA_CONF_OPTS
+= --disable-dummy
124 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_ESPNET
),y
)
125 OLA_CONF_OPTS
+= --enable-espnet
127 OLA_CONF_OPTS
+= --disable-espnet
130 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_KINET
),y
)
131 OLA_CONF_OPTS
+= --enable-kinet
133 OLA_CONF_OPTS
+= --disable-kinet
136 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_OSC
),y
)
137 OLA_CONF_OPTS
+= --enable-osc
138 OLA_DEPENDENCIES
+= liblo
140 OLA_CONF_OPTS
+= --disable-osc
143 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_MILINT
),y
)
144 OLA_CONF_OPTS
+= --enable-milinst
146 OLA_CONF_OPTS
+= --disable-milinst
149 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_PATHPORT
),y
)
150 OLA_CONF_OPTS
+= --enable-pathport
152 OLA_CONF_OPTS
+= --disable-pathport
155 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SANDNET
),y
)
156 OLA_CONF_OPTS
+= --enable-sandnet
158 OLA_CONF_OPTS
+= --disable-sandnet
161 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_SHOWNET
),y
)
162 OLA_CONF_OPTS
+= --enable-shownet
164 OLA_CONF_OPTS
+= --disable-shownet
167 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_STAGEPROFI
),y
)
168 OLA_CONF_OPTS
+= --enable-stageprofi
--enable-libusb
170 OLA_CONF_OPTS
+= --disable-stageprofi
173 ifeq ($(BR2_PACKAGE_OLA_PLUGIN_USBPRO
),y
)
174 OLA_CONF_OPTS
+= --enable-usbpro
--enable-libusb
176 OLA_CONF_OPTS
+= --disable-usbpro
179 $(eval
$(autotools-package
))
180 $(eval
$(host-autotools-package
))