iptables: bump to version 1.6.1
[buildroot-gz.git] / package / sngrep / sngrep.mk
blob52c8a2da4e0c1eec1568ee8fb9af607558da01a9
1 ################################################################################
3 # sngrep
5 ################################################################################
7 SNGREP_VERSION = v1.4.2
8 SNGREP_SITE = $(call github,irontec,sngrep,$(SNGREP_VERSION))
9 SNGREP_LICENSE = GPLv3+
10 SNGREP_LICENSE_FILES = LICENSE
11 SNGREP_AUTORECONF = YES
12 SNGREP_DEPENDENCIES = libpcap ncurses
14 # our ncurses wchar support is not properly detected
15 SNGREP_CONF_OPTS += --disable-unicode
17 # openssl and gnutls can't be enabled at the same time.
18 ifeq ($(BR2_PACKAGE_OPENSSL),y)
19 SNGREP_DEPENDENCIES += openssl
20 SNGREP_CONF_OPTS += --with-openssl --without-gnutls
21 # gnutls support also requires libgcrypt
22 else ifeq ($(BR2_PACKAGE_GNUTLS)$(BR2_PACKAGE_LIBGCRYPT),yy)
23 SNGREP_DEPENDENCIES += gnutls
24 SNGREP_CONF_OPTS += --with-gnutls --without-openssl
25 else
26 SNGREP_CONF_OPTS += --without-gnutls --without-openssl
27 endif
29 ifeq ($(BR2_PACKAGE_PCRE),y)
30 SNGREP_DEPENDENCIES += pcre
31 SNGREP_CONF_OPTS += --with-pcre
32 else
33 SNGREP_CONF_OPTS += --without-pcre
34 endif
36 $(eval $(autotools-package))