configs/bananapro: bump Linux to 4.10.4
[buildroot-gz.git] / package / s6 / s6.mk
blobde08f67848cd4a6166b02f7e00044b3a8ac30527
1 ################################################################################
3 # s6
5 ################################################################################
7 S6_VERSION = 2.4.0.0
8 S6_SITE = http://skarnet.org/software/s6
9 S6_LICENSE = ISC
10 S6_LICENSE_FILES = COPYING
11 S6_INSTALL_STAGING = YES
12 S6_DEPENDENCIES = execline
14 S6_CONF_OPTS = \
15 --prefix=/usr \
16 --with-sysdeps=$(STAGING_DIR)/usr/lib/skalibs/sysdeps \
17 --with-include=$(STAGING_DIR)/usr/include \
18 --with-dynlib=$(STAGING_DIR)/usr/lib \
19 --with-lib=$(STAGING_DIR)/usr/lib/execline \
20 --with-lib=$(STAGING_DIR)/usr/lib/skalibs \
21 $(if $(BR2_STATIC_LIBS),,--disable-allstatic) \
22 $(SHARED_STATIC_LIBS_OPTS)
24 define S6_CONFIGURE_CMDS
25 (cd $(@D); $(TARGET_CONFIGURE_OPTS) ./configure $(S6_CONF_OPTS))
26 endef
28 define S6_BUILD_CMDS
29 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
30 endef
32 define S6_INSTALL_TARGET_CMDS
33 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
34 endef
36 define S6_REMOVE_STATIC_LIB_DIR
37 rm -rf $(TARGET_DIR)/usr/lib/s6
38 endef
40 S6_POST_INSTALL_TARGET_HOOKS += S6_REMOVE_STATIC_LIB_DIR
42 define S6_INSTALL_STAGING_CMDS
43 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) install
44 endef
46 HOST_S6_DEPENDENCIES = host-execline
48 HOST_S6_CONF_OPTS = \
49 --prefix=$(HOST_DIR)/usr \
50 --with-sysdeps=$(HOST_DIR)/usr/lib/skalibs/sysdeps \
51 --with-include=$(HOST_DIR)/usr/include \
52 --with-dynlib=$(HOST_DIR)/usr/lib \
53 --disable-static \
54 --enable-shared \
55 --disable-allstatic
57 define HOST_S6_CONFIGURE_CMDS
58 (cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure $(HOST_S6_CONF_OPTS))
59 endef
61 define HOST_S6_BUILD_CMDS
62 $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
63 endef
65 define HOST_S6_INSTALL_CMDS
66 $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install-dynlib install-include
67 endef
69 $(eval $(generic-package))
70 $(eval $(host-generic-package))