configs/bananapro: bump Linux to 4.10.4
[buildroot-gz.git] / package / shellinabox / shellinabox.mk
blob1173ef7d1ca89c1ae568e1faeb976c00c063c067
1 ################################################################################
3 # shellinabox
5 ################################################################################
7 SHELLINABOX_VERSION = v2.19
8 SHELLINABOX_SITE = $(call github,shellinabox,shellinabox,$(SHELLINABOX_VERSION))
9 SHELLINABOX_LICENSE = GPLv2 with OpenSSL exception
10 SHELLINABOX_LICENSE_FILES = COPYING GPL-2
12 # Fetching from Github, and patching Makefile.am, so we need to autoreconf
13 SHELLINABOX_AUTORECONF = YES
15 # The OpenSSL support is supposed to be optional, but in practice,
16 # with OpenSSL disabled, it fails to build. See
17 # https://github.com/shellinabox/shellinabox/issues/385.
18 SHELLINABOX_DEPENDENCIES = zlib openssl
19 SHELLINABOX_CONF_OPTS = \
20 --disable-runtime-loading \
21 --enable-ssl
23 # musl's implementation of utmpx is a dummy one, and some aspects of
24 # it cause build failures in shellinabox
25 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
26 SHELLINABOX_CONF_ENV += ac_cv_header_utmpx_h=no
27 endif
29 $(eval $(autotools-package))