glib-networking: bump to version 2.48.1
[buildroot-gz.git] / package / mediastreamer / mediastreamer.mk
bloba12bfb4b2d4722499176abde1abb212c7b19c55b
1 ################################################################################
3 # mediastreamer
5 ################################################################################
7 MEDIASTREAMER_VERSION = 2.12.1
8 MEDIASTREAMER_SITE = http://download.savannah.nongnu.org/releases/linphone/mediastreamer
9 MEDIASTREAMER_INSTALL_STAGING = YES
10 MEDIASTREAMER_DEPENDENCIES = host-intltool host-pkgconf ortp host-gettext
11 # tests fail linking on some architectures, so disable them
12 MEDIASTREAMER_CONF_OPTS = --disable-tests --disable-glx --disable-strict
13 MEDIASTREAMER_LICENSE = GPLv2+
14 MEDIASTREAMER_LICENSE_FILES = COPYING
16 ifeq ($(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yy)
17 MEDIASTREAMER_CONF_OPTS += --enable-alsa
18 MEDIASTREAMER_DEPENDENCIES += alsa-lib
19 else
20 MEDIASTREAMER_CONF_OPTS += --disable-alsa
21 endif
23 ifeq ($(BR2_PACKAGE_LIBUPNP),y)
24 MEDIASTREAMER_CONF_OPTS += --enable-upnp
25 MEDIASTREAMER_DEPENDENCIES += libupnp
26 else
27 MEDIASTREAMER_CONF_OPTS += --disable-upnp
28 endif
30 ifeq ($(BR2_PACKAGE_LIBVPX),y)
31 MEDIASTREAMER_CONF_OPTS += --enable-vp8
32 MEDIASTREAMER_DEPENDENCIES += libvpx
33 else
34 MEDIASTREAMER_CONF_OPTS += --disable-vp8
35 endif
37 ifeq ($(BR2_PACKAGE_OPUS),y)
38 MEDIASTREAMER_CONF_OPTS += --enable-opus
39 MEDIASTREAMER_DEPENDENCIES += opus
40 else
41 MEDIASTREAMER_CONF_OPTS += --disable-opus
42 endif
44 # portaudio backend needs speex as well
45 ifeq ($(BR2_PACKAGE_PORTAUDIO)$(BR2_PACKAGE_SPEEX),yy)
46 MEDIASTREAMER_CONF_OPTS += --enable-portaudio
47 MEDIASTREAMER_DEPENDENCIES += portaudio speex
48 else
49 MEDIASTREAMER_CONF_OPTS += --disable-portaudio
50 endif
52 ifeq ($(BR2_PACKAGE_PULSEAUDIO),y)
53 MEDIASTREAMER_CONF_OPTS += --enable-pulseaudio
54 MEDIASTREAMER_DEPENDENCIES += pulseaudio
55 else
56 MEDIASTREAMER_CONF_OPTS += --disable-pulseaudio
57 endif
59 ifeq ($(BR2_PACKAGE_SPEEX),y)
60 MEDIASTREAMER_CONF_OPTS += --enable-speex
61 MEDIASTREAMER_DEPENDENCIES += speex
62 else
63 MEDIASTREAMER_CONF_OPTS += --disable-speex
64 endif
66 ifeq ($(BR2_PACKAGE_FFMPEG_SWSCALE),y)
67 MEDIASTREAMER_CONF_OPTS += --enable-ffmpeg
68 MEDIASTREAMER_DEPENDENCIES += ffmpeg
69 else
70 MEDIASTREAMER_CONF_OPTS += --disable-ffmpeg
71 endif
73 ifeq ($(BR2_PACKAGE_SDL),y)
74 MEDIASTREAMER_CONF_OPTS += --enable-sdl
75 MEDIASTREAMER_DEPENDENCIES += sdl
76 else
77 MEDIASTREAMER_CONF_OPTS += --disable-sdl
78 endif
80 # mediastreamer assumes SDL has X11 support if --enable-x11 (and X11 support
81 # is only used for SDL output)
82 ifeq ($(BR2_PACKAGE_SDL_X11),y)
83 MEDIASTREAMER_CONF_OPTS += --enable-x11
84 else
85 MEDIASTREAMER_CONF_OPTS += --disable-x11
86 endif
88 ifeq ($(BR2_PACKAGE_XLIB_LIBXV),y)
89 MEDIASTREAMER_CONF_OPTS += --enable-xv
90 MEDIASTREAMER_DEPENDENCIES += xlib_libXv
91 else
92 MEDIASTREAMER_CONF_OPTS += --disable-xv
93 endif
95 ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
96 MEDIASTREAMER_CONF_OPTS += --enable-theora
97 MEDIASTREAMER_DEPENDENCIES += libtheora
98 else
99 MEDIASTREAMER_CONF_OPTS += --disable-theora
100 endif
102 ifeq ($(BR2_PACKAGE_LIBV4L),y)
103 MEDIASTREAMER_CONF_OPTS += --enable-libv4l1 --enable-libv4l2
104 MEDIASTREAMER_DEPENDENCIES += libv4l
105 else
106 MEDIASTREAMER_CONF_OPTS += --disable-libv4l1 --disable-libv4l2
107 endif
109 $(eval $(autotools-package))