1 ################################################################################
5 ################################################################################
7 PHP_SSH2_VERSION
= 12dd52236c601577a63e33ee71e3ce6dad811e40
8 PHP_SSH2_SITE
= $(call github
,php
,pecl-networking-ssh2
,$(PHP_SSH2_VERSION
))
9 PHP_SSH2_CONF_OPTS
= --with-php-config
=$(STAGING_DIR
)/usr
/bin
/php-config \
10 --with-ssh2
=$(STAGING_DIR
)/usr
11 # phpize does the autoconf magic
12 PHP_SSH2_DEPENDENCIES
= libssh2 php host-autoconf
13 PHP_SSH2_LICENSE
= PHP
14 PHP_SSH2_LICENSE_FILES
= LICENSE
16 define PHP_SSH2_PHPIZE
18 PHP_AUTOCONF
=$(HOST_DIR
)/usr
/bin
/autoconf \
19 PHP_AUTOHEADER
=$(HOST_DIR
)/usr
/bin
/autoheader \
20 $(STAGING_DIR
)/usr
/bin
/phpize
)
23 PHP_SSH2_PRE_CONFIGURE_HOOKS
+= PHP_SSH2_PHPIZE
25 $(eval
$(autotools-package
))