package/libxslt: fix static build
[buildroot-gz.git] / package / gnuplot / gnuplot.mk
blob4408ece5be36aa32a1b00907f4c76b163b55405d
1 ################################################################################
3 # gnuplot
5 ################################################################################
7 GNUPLOT_VERSION = 4.6.6
8 GNUPLOT_SITE = http://downloads.sourceforge.net/project/gnuplot/gnuplot/$(GNUPLOT_VERSION)
9 GNUPLOT_LICENSE = gnuplot license (open source)
10 GNUPLOT_LICENSE_FILES = Copyright
12 GNUPLOT_AUTORECONF = YES
14 GNUPLOT_CONF_OPTS = \
15 --without-x \
16 --disable-raise-console \
17 --disable-mouse \
18 --without-tutorial \
19 --disable-demo \
20 --without-row-help \
21 --disable-history-file \
22 --without-lisp-files \
23 --disable-wxwidgets \
24 --without-lua \
25 --without-latex \
26 --without-cairo
28 ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
29 GNUPLOT_CONF_OPTS += --with-gd
30 GNUPLOT_DEPENDENCIES += gd
31 GNUPLOT_CONF_ENV += \
32 ac_cv_path_GDLIB_CONFIG=$(STAGING_DIR)/usr/bin/gdlib-config
33 else
34 GNUPLOT_CONF_OPTS += --without-gd
35 endif
37 ifeq ($(BR2_PACKAGE_READLINE),y)
38 GNUPLOT_CONF_OPTS += --with-readline=gnu
39 GNUPLOT_DEPENDENCIES += readline
40 else
41 GNUPLOT_CONF_OPTS += --without-readline
42 endif
44 # Remove Javascript scripts, lua scripts, PostScript files
45 define GNUPLOT_REMOVE_UNNEEDED_FILES
46 $(RM) -rf $(TARGET_DIR)/usr/share/gnuplot
47 endef
49 GNUPLOT_POST_INSTALL_TARGET_HOOKS += GNUPLOT_REMOVE_UNNEEDED_FILES
51 $(eval $(autotools-package))