package/xfont_font-cronyx-cyrillic: add hash file
[buildroot-gz.git] / package / norm / norm.mk
blobe1b3a5fcc2f4f247ae99ab9e68a5d46aac4d2fde
1 ################################################################################
3 # norm
5 ################################################################################
7 NORM_VERSION = 1.5r6
8 NORM_SITE = http://downloads.pf.itd.nrl.navy.mil/norm/archive
9 NORM_SOURCE = src-norm-$(NORM_VERSION).tgz
10 NORM_INSTALL_STAGING = YES
11 NORM_LICENSE = NRL License
12 NORM_LICENSE_FILES = LICENSE.TXT
14 ifeq ($(BR2_PACKAGE_LIBNETFILTER_QUEUE),y)
15 NORM_DEPENDENCIES += libnetfilter_queue
16 endif
18 define NORM_CONFIGURE_CMDS
19 cd $(@D); \
20 $(TARGET_CONFIGURE_OPTS) \
21 ./waf configure --prefix=/usr
22 endef
24 define NORM_BUILD_CMDS
25 cd $(@D); \
26 $(TARGET_MAKE_ENV) \
27 ./waf build
28 endef
30 # install target doesn't install headers unfortunately...
31 define NORM_INSTALL_STAGING_CMDS
32 cd $(@D); \
33 $(TARGET_MAKE_ENV) \
34 DESTDIR=$(STAGING_DIR) \
35 ./waf install
36 cp -f $(@D)/include/norm* $(STAGING_DIR)/usr/include
37 endef
39 define NORM_INSTALL_TARGET_CMDS
40 cd $(@D); \
41 $(TARGET_MAKE_ENV) \
42 DESTDIR=$(TARGET_DIR) \
43 ./waf install
44 endef
46 $(eval $(generic-package))