package/xfont_font-cronyx-cyrillic: add hash file
[buildroot-gz.git] / package / openvpn / openvpn.mk
blobf3985cd2ef05dc78aceaa5c249f6994878e3702d
1 ################################################################################
3 # openvpn
5 ################################################################################
7 OPENVPN_VERSION = 2.3.11
8 OPENVPN_SOURCE = openvpn-$(OPENVPN_VERSION).tar.xz
9 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
10 OPENVPN_DEPENDENCIES = host-pkgconf openssl
11 OPENVPN_LICENSE = GPLv2
12 OPENVPN_LICENSE_FILES = COPYRIGHT.GPL
13 OPENVPN_CONF_OPTS = \
14 --disable-plugin-auth-pam \
15 --enable-iproute2 \
16 --with-crypto-library=openssl \
17 $(if $(BR2_STATIC_LIBS),--disable-plugins)
18 OPENVPN_CONF_ENV = IFCONFIG=/sbin/ifconfig \
19 NETSTAT=/bin/netstat \
20 ROUTE=/sbin/route
22 ifeq ($(BR2_PACKAGE_OPENVPN_SMALL),y)
23 OPENVPN_CONF_OPTS += \
24 --enable-small \
25 --disable-plugins \
26 --disable-eurephia
27 endif
29 # BusyBox 1.21+ places the ip applet in the "correct" place
30 # but previous versions didn't.
31 ifeq ($(BR2_PACKAGE_IPROUTE2),y)
32 OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
33 else ifeq ($(BR2_BUSYBOX_VERSION_1_19_X)$(BR2_BUSYBOX_VERSION_1_20_X),y)
34 OPENVPN_CONF_ENV += IPROUTE=/bin/ip
35 else
36 OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
37 endif
39 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
40 OPENVPN_DEPENDENCIES += lzo
41 else
42 OPENVPN_CONF_OPTS += --disable-lzo
43 endif
45 ifeq ($(BR2_PACKAGE_OPENVPN_PWSAVE),y)
46 OPENVPN_CONF_OPTS += --enable-password-save
47 else
48 OPENVPN_CONF_OPTS += --disable-password-save
49 endif
51 define OPENVPN_INSTALL_TARGET_CMDS
52 $(INSTALL) -m 755 $(@D)/src/openvpn/openvpn \
53 $(TARGET_DIR)/usr/sbin/openvpn
54 endef
56 define OPENVPN_INSTALL_INIT_SYSV
57 $(INSTALL) -m 755 -D package/openvpn/S60openvpn \
58 $(TARGET_DIR)/etc/init.d/S60openvpn
59 endef
61 $(eval $(autotools-package))