package/dhcp/S80dhcp-server: allow empty INTERFACES
[buildroot-gz.git] / package / gpm / gpm.mk
blob6d3b5d2dc2a58e44f4f283505099a8fc1845fe82
1 ################################################################################
3 # gpm
5 ################################################################################
7 GPM_VERSION = 1.20.7
8 GPM_SOURCE = gpm-$(GPM_VERSION).tar.lzma
9 GPM_SITE = http://www.nico.schottelius.org/software/gpm/archives
10 GPM_LICENSE = GPLv2+
11 GPM_LICENSE_FILES = COPYING
12 GPM_INSTALL_STAGING = YES
13 GPM_DEPENDENCIES = host-bison
15 # if not already installed in staging dir, gpm Makefile may fail to find some
16 # of the headers needed to generate build dependencies, the first time it is
17 # built. CPPFLAGS is used to pass the right include path to dependency rules.
18 GPM_CONF_ENV = CPPFLAGS="$(TARGET_CPPFLAGS) -I$(@D)/src/headers/" \
19 ac_cv_path_emacs=no
21 # For some reason, Microblaze gcc does not define __ELF__, which gpm
22 # configure script uses to determine whether the architecture uses ELF
23 # binaries and therefore can build shared libraries. We fix this by
24 # telling GPM that ELF is used on Microblaze.
25 ifeq ($(BR2_microblaze),y)
26 GPM_CONF_ENV += itz_cv_sys_elf=yes
27 endif
29 # gpm and ncurses have a circular dependency. As gpm function GPM_Wgetch()
30 # (requiring ncurses) is not recommended for use by ncurses people themselves
31 # and as it's better to have gpm support in ncurses that the contrary, we force
32 # gpm to not look after ncurses explicitly.
33 # http://invisible-island.net/ncurses/ncurses.faq.html#using_gpm_lib
34 GPM_CONF_OPTS = --without-curses
36 # configure is missing but gpm seems not compatible with our autoreconf
37 # mechanism so we have to do it manually instead of using GPM_AUTORECONF = YES
38 define GPM_RUN_AUTOGEN
39 cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
40 endef
41 GPM_PRE_CONFIGURE_HOOKS += GPM_RUN_AUTOGEN
43 GPM_DEPENDENCIES += host-automake host-autoconf host-libtool
45 # gpm tries to build/install .info doc even if makeinfo isn't installed on the
46 # host, so we have to disable global doc installation to prevent autobuild
47 # errors.
48 define GPM_DISABLE_DOC_INSTALL
49 $(SED) 's/SUBDIRS = src doc contrib/SUBDIRS = src contrib/' \
50 $(@D)/Makefile.in
51 endef
52 GPM_POST_PATCH_HOOKS += GPM_DISABLE_DOC_INSTALL
54 ifeq ($(BR2_PACKAGE_GPM_INSTALL_TEST_TOOLS),)
55 define GPM_REMOVE_TEST_TOOLS_FROM_TARGET
56 for tools in mev hltest mouse-test display-buttons \
57 get-versions display-coords; do \
58 rm -f $(TARGET_DIR)/usr/bin/$$tools ; \
59 done
60 endef
61 GPM_POST_INSTALL_TARGET_HOOKS += GPM_REMOVE_TEST_TOOLS_FROM_TARGET
62 endif
64 define GPM_INSTALL_GPM_ROOT_CONF_ON_TARGET
65 $(INSTALL) -m 0644 -D $(@D)/conf/gpm-root.conf $(TARGET_DIR)/etc/
66 endef
68 GPM_POST_INSTALL_TARGET_HOOKS += GPM_INSTALL_GPM_ROOT_CONF_ON_TARGET
70 $(eval $(autotools-package))