1 ################################################################################
5 ################################################################################
7 GTKMM3_VERSION_MAJOR
= 3.14
8 GTKMM3_VERSION
= $(GTKMM3_VERSION_MAJOR
).0
9 GTKMM3_SOURCE
= gtkmm-
$(GTKMM3_VERSION
).
tar.xz
10 GTKMM3_SITE
= http
://ftp.gnome.org
/pub
/gnome
/sources
/gtkmm
/$(GTKMM3_VERSION_MAJOR
)
11 GTKMM3_LICENSE
= LGPLv2.1
+ (library
), GPLv2
+ (tools
)
12 GTKMM3_LICENSE_FILES
= COPYING COPYING.tools
13 GTKMM3_INSTALL_STAGING
= YES
14 GTKMM3_DEPENDENCIES
= atkmm cairomm glibmm libgtk3 libsigc pangomm host-pkgconf
16 # Explicit use of C++11 to build with newer *mm dependencies that require C++11.
18 # The most recent release of *mm-related libraries require C++11. This project's
19 # dependencies (ex. libpangomm) are updated and enforce the C++11 standard.
20 # Since the gtkmm3 must match the libgtk3 version, the useable version of
21 # gtkmm3 does not have this enforcement; however, to build with the most
22 # recent version of the dependencies, gtkmm3 requires to be built with
23 # `-std=c++11`. The following enforces C++11 standard. When libgtk3 is updated,
24 # followed by a gtkmm3 update, this flag modification can be removed.
25 GTKMM3_CONF_ENV
= CPPFLAGS
="$(TARGET_CPPFLAGS) -std=c++11"
27 $(eval
$(autotools-package
))