1 ################################################################################
5 ################################################################################
7 HEIMDAL_VERSION
= 1.6rc2
8 HEIMDAL_SITE
= http
://www.h5l.org
/dist/src
9 HEIMDAL_DEPENDENCIES
= host-e2fsprogs host-ncurses host-pkgconf
10 HEIMDAL_INSTALL_STAGING
= YES
11 # static because of -fPIC issues with e2fsprogs on x86_64 host
12 HOST_HEIMDAL_CONF_OPTS
= \
20 --without-berkeley-db \
25 --disable-heimdal-documentation
26 HOST_HEIMDAL_CONF_ENV
= MAKEINFO
=true
27 HEIMDAL_MAKE
= $(MAKE1
)
28 HEIMDAL_LICENSE
= BSD-3c
29 HEIMDAL_LICENSE_FILES
= LICENSE
30 # 0002-kadm5-fix-race-in-Makefile-with-kadm5_err.h.patch
31 HEIMDAL_AUTORECONF
= YES
33 # We need asn1_compile in the PATH for samba4
34 define HOST_HEIMDAL_MAKE_SYMLINK
35 ln
-sf
$(HOST_DIR
)/usr
/libexec
/heimdal
/asn1_compile \
36 $(HOST_DIR
)/usr
/bin
/asn1_compile
37 ln
-sf
$(HOST_DIR
)/usr
/bin
/compile_et \
38 $(HOST_DIR
)/usr
/libexec
/heimdal
/compile_et
41 HOST_HEIMDAL_POST_INSTALL_HOOKS
+= HOST_HEIMDAL_MAKE_SYMLINK
43 $(eval
$(host-autotools-package
))