1 ################################################################################
5 ################################################################################
7 JANUS_GATEWAY_VERSION
= c632c1e9da5ffd8c34df6086a1aa5a8511a2a02d
8 JANUS_GATEWAY_SITE
= $(call github
,meetecho
,janus-gateway
,$(JANUS_GATEWAY_VERSION
))
9 JANUS_GATEWAY_LICENSE
= GPLv3
10 JANUS_GATEWAY_LICENSE_FILES
= COPYING
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES
= host-pkgconf libmicrohttpd jansson \
14 libnice sofia-sip libsrtp host-gengetopt openssl ding-libs
16 # Straight out of the repository, no ./configure, and we also patch
18 JANUS_GATEWAY_AUTORECONF
= YES
20 define JANUS_GATEWAY_M4
23 JANUS_GATEWAY_POST_PATCH_HOOKS
+= JANUS_GATEWAY_M4
25 JANUS_GATEWAY_CONF_OPTS
= \
26 --disable-data-channels \
29 ifeq ($(BR2_PACKAGE_LIBWEBSOCK
),y
)
30 JANUS_GATEWAY_DEPENDENCIES
+= libwebsock
31 JANUS_GATEWAY_CONF_OPTS
+= --enable-websockets
33 JANUS_GATEWAY_CONF_OPTS
+= --disable-websockets
36 ifeq ($(BR2_PACKAGE_OPUS
),y
)
37 JANUS_GATEWAY_DEPENDENCIES
+= opus
38 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-audiobridge
40 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-audiobridge
43 ifeq ($(BR2_PACKAGE_LIBOGG
),y
)
44 JANUS_GATEWAY_DEPENDENCIES
+= libogg
45 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-voicemail
47 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-voicemail
50 # Parallel build broken
51 JANUS_GATEWAY_MAKE
= $(MAKE1
)
53 $(eval
$(autotools-package
))